Page tree
Skip to end of metadata
Go to start of metadata

Introduction

CSCS tests all new operating systems to ensure that they are compatible with our storage, authentication, patching and deployment systems. Once a product has passed core testing we make it available on request via the Service Desk for our more technical users while we prepare deployments, train support staff and prepare documentation.

When everything is ready and we are able to offer comprehensive support, we will make it generally available.

We will generally continue support an operating system until it no longer receives security updates from it's manufacturer, but as newer versions are released, we inevitably become less familiar with older operating systems,

OS Versions and Their Support Level


 Supported Windows Editions

CSCS Support LevelSecurity Patch End DateRecommended Action if using this product
Windows 2000 / 98
Unsupported

Support ended

Upgrade required - contact the Service Desk for advice.
Windows XP SP3
Reduced support

Support ended  

See page on Windows XP Upgrade Project
Windows Vista SP2
Reduced support

Support ends  

Contact the Service Desk to arrange an upgrade to Windows 7 or 10
Windows 7 SP1
Fully supported

Support ends  

No action required
Windows 8

Unsupported

Support ended  

Contact the Service Desk to arrange an upgrade to Windows 7 or 10
Windows 8.1Unsupported

Support ends  

Contact the Service Desk to arrange an upgrade to Windows 7 or 10
Windows 10 Version 1507
Unsupported

Support ends  

Contact the Service Desk to arrange an upgrade to newer build of Windows 10
Windows 10 Version 1511
Reduced support

Support ends   

No action required
Windows 10 Version 1607
Fully supported

Support ends  

No action required
Windows 10 Version 1703
Early support

Support ends 

No action required
Windows 10 Version 1709Not yet supported

Support ends  


 Supported macOS / OS X Versions

CSCS Support LevelEnd of Apple SupportRecommended Action if using this product
10.5 "Leopard"UnsupportedSupport ended 2012Upgrade required - contact the Service Desk for advice.
10.6 "Snow Leopard"UnsupportedSupport ended 2013Upgrade required - contact the Service Desk for advice.
10.7 "Lion"UnsupportedSupport ended 2014Upgrade required - contact the Service Desk to arrange
10.8 "Mountain Lion"UnsupportedSupport ended 2015Upgrade required - contact the Service Desk to arrange
10.9 "Mavericks"UnsupportedSupport ended 2016Upgrade required - contact the Service Desk to arrange
10.10 "Yosemite"UnsupportedSupport ending 2017Upgrade required - contact the Service Desk to arrange
10.11 "El Capitan"Fully supportedUnknownNo action required
10.12 "Sierra"Fully supportedUnknownNo action required
10.13 "High Sierra"Early supportUnknownNo action required
 Supported Ubuntu Versions

CSCS Support LevelEnd of Canonical SupportRecommended Action if using this product
12.04 LTSReduced supportSupport ended April 2017Upgrade required - contact the Service Desk to arrange
14.04 LTSFully supportedSupport ending April 2019No action required
16.04 LTSNot yet supported

Key to Support Levels

Unsupported
  • Compatibility problems expected
  • Represents a security risk
  • CSCS will not support or deploy this product
  • CSCS will assist you in moving to a fully supported platform
Reduced support
  • The product is no longer current
  • Support staff may have lost familiarity with using this product
  • Compatibility problems with other applications or systems are likely
  • CSCS Services are no longer tested to ensure compatibility
  • CSCS will not deploy this product unless in exceptional circumstances
  • CSCS will assist you in moving to a fully supported platform
Full support
  • The product is current
  • The majority of support staff are very familiar
  • CSCS Services are tested for compatibility with this product
  • CSCS maintains deployments for this product

Early support
  • The product has been tested for use with core CSCS Services (authentication, storage, patching)
  • Issues may be present in certain use-case scenarios
  • Care may be needed when upgrading to this product
  • Some support staff are familiar with this product
  • Documentation is minimal
  • The product can be installed upon request to technical users that accept slower response times and can cope with potential problems encountered
Not yet Supported
  • The product has recently been released
  • The product is undergoing testing for compatibility
  • CSCS recommend that you do not use this product
  • CSCS will not support or deploy this product

supported os



  • No labels